WaKan Project Website Forum Index WaKan Project Website
Forums about WaKan and Japanese & Chinese language
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

furigana in microsoft word

 
Post new topic   Reply to topic    WaKan Project Website Forum Index -> Japanese language
View previous topic :: View next topic  
Author Message
Dir.en.Rei



Joined: 26 Dec 2006
Posts: 25
Location: Sydney, Australia

PostPosted: Sun Oct 19, 2008 7:24 am    Post subject: furigana in microsoft word Reply with quote

would someone be able to tell me how to enter furigana in Microsoft Word? I'm writing some notes and I'd much prefer having furigana rather than having parentheses within parentheses.

I'm just entering grammar notes and the like so I'm using both English and Japanese script. hope somebody can help Confused
_________________
--Ray
Back to top
View user's profile Send private message
Tom Hodgers
Co-Admin


Joined: 26 Jan 2004
Posts: 253
Location: Valencia, Venezuela via Liverpool and Manchester, England

PostPosted: Sun Oct 19, 2008 11:47 pm    Post subject: Reply with quote

Hi Ray,

It's easy to insert furigana with WORD. I have Office XP installed.

1. Open page with Japanese Kanji text, or type in with IME, or copy and paste.
2. Select Kanji word.
3. Click on Format in tool bar.
4. Select Asian Layout, then Phonetic Guide.
5. Window will pop-up with the following info:

a. Base text:Shows Kanji highlighted: Ruby text:Shows selected furigana ruby.
b. Allignment: 1-2-1 gives spacing of furigana: Offset: 1 pt. gives space between furigana and Kanji.
c. Font:Select Font : Size: 6 pt. select size furigana.
d. Review:Shows finished product.
e. OK button. Press to insert furigana.

Works perfectly for me.
Edit: Of course, you have to have the Japanese pack installed.

Cheers,

Tom
_________________
Just another
和漢 WAKAN
若人 WHACKO DOing his thing
Back to top
View user's profile Send private message Send e-mail
Dir.en.Rei



Joined: 26 Dec 2006
Posts: 25
Location: Sydney, Australia

PostPosted: Mon Oct 20, 2008 5:31 am    Post subject: Reply with quote

wah, thanks Tom but I'm using Vista and although I didn't think it'd be a problem I can't seem to find this phonetic guide. I do have the Japanese pack installed.
_________________
--Ray
Back to top
View user's profile Send private message
Tom Hodgers
Co-Admin


Joined: 26 Jan 2004
Posts: 253
Location: Valencia, Venezuela via Liverpool and Manchester, England

PostPosted: Mon Oct 20, 2008 2:06 pm    Post subject: Reply with quote

Hi Ray,

I haven't tried Vista yet, but the thing is that you will be using Word from your Office installation which, I suppose, is Office 2003 or 2007.

You may have to install the relevant Japanese pack for your OFFICE version, not the Vista version (not sure about that, just a feeling).

If I remember correctly, the phonetic guide came with my Office XP/2002 Japanese pack not the Windows XP japanese Pack.

Worth a try anyway.

Cheers,

Tom
_________________
Just another
和漢 WAKAN
若人 WHACKO DOing his thing
Back to top
View user's profile Send private message Send e-mail
Tom Hodgers
Co-Admin


Joined: 26 Jan 2004
Posts: 253
Location: Valencia, Venezuela via Liverpool and Manchester, England

PostPosted: Mon Oct 20, 2008 3:27 pm    Post subject: Reply with quote

Found it in Office 2007 Word!

At the top of the window, in Word, Office 2007, you will see a quick launch bar with, maybe, the save icon, save as, etc. To the right of this bar there is a small bar with down arrow icon. Click on this and open up the Customize Quick Access Toolbar.

Click on "More Commands" and the Word Options Toolbox will open. Click on "Customize" in the left hand column. The Customize Quick Access..... box will open.

In the "Choose commands from" box, choose "All Commands". Slide down this box to "Phonetic Guide". Press the "Add" button and then the "OK" button at the bottom of the screen.

The Phonetic Guide button (a capital A with abc above it) will now appear in the quick launch bar at the top of the screen.

Proceed to use it as I explained earlier.

It seems that Japanese, Chinese etc. comes included with Office 2007.

Make sure you have Japanese selected as your language or it may come up in Chinese.


I've just tried it on my Word 2007 and it works perfectly.

Cheers,

Tom
_________________
Just another
和漢 WAKAN
若人 WHACKO DOing his thing
Back to top
View user's profile Send private message Send e-mail
Tom Hodgers
Co-Admin


Joined: 26 Jan 2004
Posts: 253
Location: Valencia, Venezuela via Liverpool and Manchester, England

PostPosted: Mon Oct 20, 2008 9:17 pm    Post subject: Reply with quote

I've just been checking the ribbon in Word 2007 and the Phonetic Guide button may already be inserted in the HOME tab, next to the font type.

If not, do as I mentioned above.

I didn't notice this because I'm not very familiar with the ribbon. I don't use Word 2007 much, I prefer XP, and when I do I use it with the Classic Toolbar. (Google for Word 2007 ribbon old toolbar freeware).

Cheers,

Tom
_________________
Just another
和漢 WAKAN
若人 WHACKO DOing his thing
Back to top
View user's profile Send private message Send e-mail
Dir.en.Rei



Joined: 26 Dec 2006
Posts: 25
Location: Sydney, Australia

PostPosted: Tue Oct 21, 2008 11:31 am    Post subject: Reply with quote

found it Tom, and yes, it's in the ribbon already. I'm not sure if it appears by default because I already had a few different language packs.

thanks so much XD I've been mucking around with it. can't believe it was there all along -__-' its pretty inconspicuous if you ask me XP
_________________
--Ray
Back to top
View user's profile Send private message
Tom Hodgers
Co-Admin


Joined: 26 Jan 2004
Posts: 253
Location: Valencia, Venezuela via Liverpool and Manchester, England

PostPosted: Thu Oct 23, 2008 10:43 pm    Post subject: Reply with quote

Yes, most things are inconspicuous in the 2007 Ribbon.

That's the reason I went back to using the Classic Toolbar, just too much hassle with the ribbon.

Glad you found it. How're you getting on with Vista/Japanese?


Cheers,

Tom
_________________
Just another
和漢 WAKAN
若人 WHACKO DOing his thing
Back to top
View user's profile Send private message Send e-mail
Uiriamu



Joined: 26 Apr 2009
Posts: 1
Location: London

PostPosted: Sun Apr 26, 2009 2:29 pm    Post subject: How to add furigana in Word 2007 Reply with quote

Hello there.
I have been able to successfully add the Phonetic Guide button using the accurate instructions posted here, for that, thank you!
But, I don't understand why no furigana appears above the kanji when I use the Phonetic Guide button? All I get when I highlight kanji and click the Phonetic guide key is the kanji but no furigana above it?

I am using Windows XP, and Microsoft Office Word 2007.
Must I add a Japanese language pack or Japanese language on my pc for the furigana to appear?
Thank you very much.

Uiriamu
Back to top
View user's profile Send private message
Tom Hodgers
Co-Admin


Joined: 26 Jan 2004
Posts: 253
Location: Valencia, Venezuela via Liverpool and Manchester, England

PostPosted: Mon Apr 27, 2009 3:39 am    Post subject: Reply with quote

Hi Uiriamu,

You say you have Windows XP with Office 2007.

1. Do you have the Windows XP Japanese language Support activated? If not try:

a. From the 'Start Menu', select 'Control Panel'.

b. Double-click 'Regional and Language Options'.

c. Select the 'Languages' tab. Check-off the 'Install files for Easy Asian Languages' box if it has not been checked-off already. Click the 'Apply' button at the bottom of the window. Follow any necessary installation steps that may require a CD. Next, click the 'Details' button.

d. At the 'Text Services and Input Languages' window, click the 'Add' button. Select 'Japanese' from the pull-down box of 'Input Languages'. Select the 'Microsoft IME Standard etc' option from the 'Keyboard layout/IME' pull-down box. Select 'OK'.

e. Next, click the 'Language Bar' button to edit your settings. Edit the options to your own personal preferences, but necessities are the 'Show the Language bar on the desktop' and 'Show additional Language bar icons in the taskbar' boxes checked. Click 'OK' when done.

f. Click the 'Key Settings' button to edit the key settings. Set different actions to different 'Key Sequences' by highlighting the action and clicking the 'Change Key Sequence' buttons. Click 'OK' when done.

g. Select the 'Advanced' tab at the 'Text Services and Input Languages' window. Check-off the 'Extend support of advanced text services to all programs' check box. Click 'OK'.

h. Restart the computer when prompted to do so. You should now see the Language bar on your Taskbar.

i. To type in Japanese, select the language by clicking 'JP' from the choices on the Language Bar. Right click the Language Bar and select 'Adjust Language Band Position' to see all icons. The fourth icon from the left is 'Input Mode' - click this icon to choose from Hiragana, Katakana, Direct Input (normal roman characters).


2. Download the Japanese IME pack for NON-OFFICE XP.

Read the following page:

http://www.microsoft.com/windows/ie/ie6/downloads/recommended/ime/default.mspx

Pay special attention to the following:
Users without Office XP: If you do not have Office XP, you can install Global IME 5.02 here.
http://www.microsoft.com/windows/ie/downloads/recommended/ime/install.mspx

Note that Global IME 5.02 is not supported on computers running Office XP and should not be installed. Office XP users must instead install the Global IMEs for Office XP.

One (or both) of these actions should remedy your problem.


Cheers,

Tom
_________________
Just another
和漢 WAKAN
若人 WHACKO DOing his thing
Back to top
View user's profile Send private message Send e-mail
Tom Hodgers
Co-Admin


Joined: 26 Jan 2004
Posts: 253
Location: Valencia, Venezuela via Liverpool and Manchester, England

PostPosted: Mon Apr 27, 2009 4:45 am    Post subject: Reply with quote

Actually Office 2007 shouldn't need a Japanese language pack.

Try the Phonetic Guide again.

1. Open Word 2007.

2. Open Japanese text doc or change language to JP and write in Japanese using the IME. Change text to Kanji.

3. Select text with Mouse.

4. Open Phonetic Guide, make sure you select font for Japanese text. Furigana should appear above the text.

5. Select size of Furigana and separation.

6. Press OKAY.

7. Furigana should now show above Kanji in original text in Word.


Cheers,

Tom
_________________
Just another
和漢 WAKAN
若人 WHACKO DOing his thing
Back to top
View user's profile Send private message Send e-mail
ahlisbon



Joined: 09 Dec 2011
Posts: 1

PostPosted: Fri Dec 09, 2011 8:05 pm    Post subject: How do I ACTIVATE furigana? Reply with quote

Hello,

I saw this thread and thought it was a good spot to continue the conversation. I already know how to type furigana if I need it but I want to activate furigana that already exists but is not being displayed.

I'm working on a project to help make it easier to use e-format books from Aozora Bunko. They have xhtml files that display ruby above the Kanji. Awesome.

But, when I copy and paste into word, none of the furigana displays anymore. It is still possible to activate it through the phonetic guide, but I can't find a way to make every furigana display at once. It is quite tedious to try and do each word individually.

I'd appreciate any advice. As a source document I recommend using Natusme Soseki's Kokoro from Aozora Bunko: http://www.aozora.gr.jp/cards/000148/files/773_14560.html
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    WaKan Project Website Forum Index -> Japanese language All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group